#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)tchumim(\W*\w*){1,5}com"
Local $sString = "https://tchumim.com/post/10185" & @CRLF & _
"" & @CRLF & _
"RegexInWord exe tchumim com" & @CRLF & _
"" & @CRLF & _
"tchumim RegexInWord exe" & @CRLF & _
" com" & @CRLF & _
"" & @CRLF & _
"tchumim RegexInWord exe RegexInWord exe RegexInWord exe com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")