package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)tchumim(\W*\w*){1,5}com`)
var str = `https://tchumim.com/post/10185
RegexInWord exe tchumim com
tchumim RegexInWord exe
com
tchumim RegexInWord exe RegexInWord exe RegexInWord exe com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}