re = /tchumim(\W*\w*){1,5}com/m
str = 'https://tchumim.com/post/10185
RegexInWord exe tchumim com
tchumim RegexInWord exe
com
tchumim RegexInWord exe RegexInWord exe RegexInWord exe com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end