const regex = /tchumim(\W*\w*){1,5}com/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('tchumim(\\W*\\w*){1,5}com', 'gm')
const str = `https://tchumim.com/post/10185
RegexInWord exe tchumim com
tchumim RegexInWord exe
com
tchumim RegexInWord exe RegexInWord exe RegexInWord exe com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}