import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([^()]*\\)(*SKIP)(*FAIL)|;";
final String string = "abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag\n"
+ "zvc;dfasdf;asdga;asd(asd;hsfd)\n"
+ "adsg;(asdg;ASF;DFG;ASDF;);sdafdf\n"
+ "asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}