import re
regex = re.compile(r"\([^()]*\)(*SKIP)(*FAIL)|;", flags=re.MULTILINE)
test_str = ("abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag\n"
"zvc;dfasdf;asdga;asd(asd;hsfd)\n"
"adsg;(asdg;ASF;DFG;ASDF;);sdafdf\n"
"asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")