re = /\([^()]*\)(*SKIP)(*FAIL)|;/m
str = 'abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag
zvc;dfasdf;asdga;asd(asd;hsfd)
adsg;(asdg;ASF;DFG;ASDF;);sdafdf
asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end