const regex = /\([^()]*\)(*SKIP)(*FAIL)|;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\([^()]*\\)(*SKIP)(*FAIL)|;', 'gm')
const str = `abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag
zvc;dfasdf;asdga;asd(asd;hsfd)
adsg;(asdg;ASF;DFG;ASDF;);sdafdf
asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}