#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))"
Local $sString = "jon@google.com" & @CRLF & _
"jon.jacob@google.com" & @CRLF & _
"jon+jacob@google.com" & @CRLF & _
"jjacob@google.com" & @CRLF & _
"jon@google.co.uk" & @CRLF & _
"jon.jacob@google.co.uk" & @CRLF & _
"jon+jacob@google.co.uk" & @CRLF & _
"jon.jacob+tag@google.co.uk" & @CRLF & _
"j.on.jac.ob@google.co.uk" & @CRLF & _
"j.on.jac.ob+tag.tag.tag1254@google.co.uk" & @CRLF & _
"jon@test.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")