use strict;
my $str = 'jon@google.com
jon.jacob@google.com
jon+jacob@google.com
jjacob@google.com
jon@google.co.uk
jon.jacob@google.co.uk
jon+jacob@google.co.uk
jon.jacob+tag@google.co.uk
j.on.jac.ob@google.co.uk
j.on.jac.ob+tag.tag.tag1254@google.co.uk
jon@test.com
';
my $regex = qr/^(([^<>()\[\]\\.,;:\s@"]+(\.[^<>()\[\]\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}