import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(([^<>()\\[\\]\\\\.,;:\\s@\"]+(\\.[^<>()\\[\\]\\\\.,;:\\s@\"]+)*)|(\".+\"))@((\\[[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}\\.[0-9]{1,3}])|(([a-zA-Z\\-0-9]+\\.)+[a-zA-Z]{2,}))";
final String string = "jon@google.com\n"
+ "jon.jacob@google.com\n"
+ "jon+jacob@google.com\n"
+ "jjacob@google.com\n"
+ "jon@google.co.uk\n"
+ "jon.jacob@google.co.uk\n"
+ "jon+jacob@google.co.uk\n"
+ "jon.jacob+tag@google.co.uk\n"
+ "j.on.jac.ob@google.co.uk\n"
+ "j.on.jac.ob+tag.tag.tag1254@google.co.uk\n"
+ "jon@test.com\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}