$re = '/^(([^<>()\[\]\\\\.,;:\s@"]+(\.[^<>()\[\]\\\\.,;:\s@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))/m';
$str = 'jon@google.com
jon.jacob@google.com
jon+jacob@google.com
jjacob@google.com
jon@google.co.uk
jon.jacob@google.co.uk
jon+jacob@google.co.uk
jon.jacob+tag@google.co.uk
j.on.jac.ob@google.co.uk
j.on.jac.ob+tag.tag.tag1254@google.co.uk
jon@test.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);