using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(([^<>()\[\]\\.,;:\s@""]+(\.[^<>()\[\]\\.,;:\s@""]+)*)|("".+""))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))";
string input = @"jon@google.com
jon.jacob@google.com
jon+jacob@google.com
jjacob@google.com
jon@google.co.uk
jon.jacob@google.co.uk
jon+jacob@google.co.uk
jon.jacob+tag@google.co.uk
j.on.jac.ob@google.co.uk
j.on.jac.ob+tag.tag.tag1254@google.co.uk
jon@test.com
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}