#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\:)\w+(?=\:)"
Local $sString = "@here ich möchte gerne ein weiteres #highlight teilen und zwar direktes Feedback vom ulmer zelt zu unserer :BRUDAH: Scan-App auf :jay: Sunmi-Handscannern (excuse my french):" & @CRLF & _
":partyparrot:" & @CRLF & _
""Perfektes Handling, super schnell, alles top - die von Loveyourartist sind :porn: im Vergleich totaler Schrott!" :partyparrot:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")