const regex = /(?<=\:)\w+(?=\:)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\:)\\w+(?=\\:)', 'g')
const str = `@here ich möchte gerne ein weiteres #highlight teilen und zwar direktes Feedback vom ulmer zelt zu unserer :BRUDAH: Scan-App auf :jay: Sunmi-Handscannern (excuse my french):
:partyparrot:
"Perfektes Handling, super schnell, alles top - die von Loveyourartist sind :porn: im Vergleich totaler Schrott!" :partyparrot:`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}