$re = '/(?<=\:)\w+(?=\:)/';
$str = '@here ich möchte gerne ein weiteres #highlight teilen und zwar direktes Feedback vom ulmer zelt zu unserer :BRUDAH: Scan-App auf :jay: Sunmi-Handscannern (excuse my french):
:partyparrot:
"Perfektes Handling, super schnell, alles top - die von Loveyourartist sind :porn: im Vergleich totaler Schrott!" :partyparrot:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);