import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\:)\\w+(?=\\:)";
final String string = "@here ich möchte gerne ein weiteres #highlight teilen und zwar direktes Feedback vom ulmer zelt zu unserer :BRUDAH: Scan-App auf :jay: Sunmi-Handscannern (excuse my french):\n"
+ ":partyparrot:\n"
+ "\"Perfektes Handling, super schnell, alles top - die von Loveyourartist sind :porn: im Vergleich totaler Schrott!\" :partyparrot:";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}