import Foundation
let pattern = #"(?<=\:)\w+(?=\:)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
@here ich möchte gerne ein weiteres #highlight teilen und zwar direktes Feedback vom ulmer zelt zu unserer :BRUDAH: Scan-App auf :jay: Sunmi-Handscannern (excuse my french):
:partyparrot:
"Perfektes Handling, super schnell, alles top - die von Loveyourartist sind :porn: im Vergleich totaler Schrott!" :partyparrot:
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)