package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?{\s*(.+?)\s*[({]`)
var str = `Here are some example of what I'd like to capture:
query SignIn($payload: AuthCredentialsInput!) {
signIn(payload: $payload) {
token
}
}
Should retrieve signIn
mutation SendConfirmationEmail($athleteId: ID!) {
sendConfirmationEmail(athleteId: $athleteId) {
id
}
}
Should retrieve sendConfirmationEmail
mutation CreateProgram($title: String!) {
createProgram(title: $title) {
id
title
}
}
Should retrieve createProgram
query GetAllExerciseTemplates {
getAllExerciseTemplates {
id
title
}
}
Should retrieve getAllExerciseTemplates`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}