$re = '/.+?{\s*(.+?)\s*[({]/m';
$str = 'Here are some example of what I\'d like to capture:
query SignIn($payload: AuthCredentialsInput!) {
signIn(payload: $payload) {
token
}
}
Should retrieve signIn
mutation SendConfirmationEmail($athleteId: ID!) {
sendConfirmationEmail(athleteId: $athleteId) {
id
}
}
Should retrieve sendConfirmationEmail
mutation CreateProgram($title: String!) {
createProgram(title: $title) {
id
title
}
}
Should retrieve createProgram
query GetAllExerciseTemplates {
getAllExerciseTemplates {
id
title
}
}
Should retrieve getAllExerciseTemplates';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);