import re
regex = re.compile(r".+?{\s*(.+?)\s*[({]", flags=re.MULTILINE)
test_str = ("Here are some example of what I'd like to capture:\n\n"
"query SignIn($payload: AuthCredentialsInput!) {\n"
" signIn(payload: $payload) {\n"
" token\n"
" }\n"
"}\n"
"Should retrieve signIn\n\n"
"mutation SendConfirmationEmail($athleteId: ID!) {\n"
" sendConfirmationEmail(athleteId: $athleteId) {\n"
" id\n"
" }\n"
"}\n"
"Should retrieve sendConfirmationEmail\n\n"
"mutation CreateProgram($title: String!) {\n"
" createProgram(title: $title) {\n"
" id\n"
" title\n"
" }\n"
"}\n"
"Should retrieve createProgram\n\n"
"query GetAllExerciseTemplates {\n"
" getAllExerciseTemplates {\n"
" id\n"
" title\n"
" }\n"
"}\n"
"Should retrieve getAllExerciseTemplates")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")