const regex = /.+?{\s*(.+?)\s*[({]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.+?{\\s*(.+?)\\s*[({]', 'gm')
const str = `Here are some example of what I'd like to capture:
query SignIn(\$payload: AuthCredentialsInput!) {
signIn(payload: \$payload) {
token
}
}
Should retrieve signIn
mutation SendConfirmationEmail(\$athleteId: ID!) {
sendConfirmationEmail(athleteId: \$athleteId) {
id
}
}
Should retrieve sendConfirmationEmail
mutation CreateProgram(\$title: String!) {
createProgram(title: \$title) {
id
title
}
}
Should retrieve createProgram
query GetAllExerciseTemplates {
getAllExerciseTemplates {
id
title
}
}
Should retrieve getAllExerciseTemplates`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}