using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<version>[\d+\.]+\d)\.*(?<type>\w*)$";
string input = @"2.13.1801.221
2.17.1801.221.SQLServer
2.19.1801.SQLite";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}