const regex = /^(?<version>[\d+\.]+\d)\.*(?<type>\w*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?<version>[\\d+\\.]+\\d)\\.*(?<type>\\w*)$', 'gm')
const str = `2.13.1801.221
2.17.1801.221.SQLServer
2.19.1801.SQLite`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}