package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<version>[\d+\.]+\d)\.*(?<type>\w*)$`)
var str = `2.13.1801.221
2.17.1801.221.SQLServer
2.19.1801.SQLite`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}