// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<version>[\d+\.]+\d)\.*(?<type>\w*)$").unwrap();
let string = "2.13.1801.221
2.17.1801.221.SQLServer
2.19.1801.SQLite";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}