$re = '/^(?<version>[\d+\.]+\d)\.*(?<type>\w*)$/m';
$str = '2.13.1801.221
2.17.1801.221.SQLServer
2.19.1801.SQLite';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);