#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\s*(?:\band\b|,))+\s*"
Local $sString = "New York" & @CRLF & _
"New York and Texas" & @CRLF & _
"New York, Texas, and Florida"
Local $sSubst = "~|~"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)