const regex = /(?:\s*(?:\band\b|,))+\s*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\s*(?:\\band\\b|,))+\\s*', 'gm')
const str = `New York
New York and Texas
New York, Texas, and Florida`;
const subst = `~|~`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);