using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\s*(?:\band\b|,))+\s*";
string substitution = @"~|~";
string input = @"New York
New York and Texas
New York, Texas, and Florida";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}