$re = '/(?:\s*(?:\band\b|,))+\s*/m';
$str = 'New York
New York and Texas
New York, Texas, and Florida';
$subst = "~|~";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;