re = /(?:\s*(?:\band\b|,))+\s*/m
str = 'New York
New York and Texas
New York, Texas, and Florida'
subst = '~|~'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result