#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "SELECT(.+)\s+FROM\s+(\w+)\s+(WHERE\s+(\w+\s*=\s*\d+))?\s*(REGION\s+(\w+))?"
Local $sString = "SELECT chr, pos FROM variants " & @CRLF & _
"SELECT chr, pos FROM variants WHERE chr=3" & @CRLF & _
"SELECT chr, pos FROM variants WHERE chr=3 REGION exonic " & @CRLF & _
"SELECT chr, pos FROM variants REGION exonic"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")