// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"SELECT(.+)\s+FROM\s+(\w+)\s+(WHERE\s+(\w+\s*=\s*\d+))?\s*(REGION\s+(\w+))?").unwrap();
let string = "SELECT chr, pos FROM variants
SELECT chr, pos FROM variants WHERE chr=3
SELECT chr, pos FROM variants WHERE chr=3 REGION exonic
SELECT chr, pos FROM variants REGION exonic";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}