using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"SELECT(.+)\s+FROM\s+(\w+)\s+(WHERE\s+(\w+\s*=\s*\d+))?\s*(REGION\s+(\w+))?";
string input = @"SELECT chr, pos FROM variants
SELECT chr, pos FROM variants WHERE chr=3
SELECT chr, pos FROM variants WHERE chr=3 REGION exonic
SELECT chr, pos FROM variants REGION exonic";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}