$re = '/SELECT(.+)\s+FROM\s+(\w+)\s+(WHERE\s+(\w+\s*=\s*\d+))?\s*(REGION\s+(\w+))?/';
$str = 'SELECT chr, pos FROM variants
SELECT chr, pos FROM variants WHERE chr=3
SELECT chr, pos FROM variants WHERE chr=3 REGION exonic
SELECT chr, pos FROM variants REGION exonic';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);