package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`SELECT(.+)\s+FROM\s+(\w+)\s+(WHERE\s+(\w+\s*=\s*\d+))?\s*(REGION\s+(\w+))?`)
var str = `SELECT chr, pos FROM variants
SELECT chr, pos FROM variants WHERE chr=3
SELECT chr, pos FROM variants WHERE chr=3 REGION exonic
SELECT chr, pos FROM variants REGION exonic`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}