# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^0+\.[.0]*//gm;t' <<< "0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.
0.0.0.0"