#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^0+\.[.0]*"
Local $sString = "0.0.4.1 # 1." & @CRLF & _
"7.51.4.1 # 2." & @CRLF & _
"0.1.4.1 # 3." & @CRLF & _
"0.0.0.0"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)