use strict;
my $str = '0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.
0.0.0.0';
my $regex = qr/^0+\.[.0]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";