package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0+\.[.0]*`)
var str = `0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.
0.0.0.0`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}