$re = '/^0+\.[.0]*/m';
$str = '0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.
0.0.0.0';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;