import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Заявка на забор документов)\\n(Имя - )(.*)\\n(Фамилия - )(.*)\\n(E-mail - )(.*)\\n(Мобильный телефон - )(.*)\\n(Улица - )(.*)\\n(Дом - )(.*)\\n(Корпус - )(.*)\\n(Строение - )(.*)\\n(Квартира - )(.*)\\n(Время забора документов - )(.*)\\n(Комментарий - )(.*)";
final String string = "Заявка на забор документов\n"
+ "Имя - Владимир\n"
+ "Фамилия - Симигин\n"
+ "E-mail - v.simigin@gmail.com\n"
+ "Мобильный телефон - +79141861116\n"
+ "Улица - Большая Черемушкинская\n"
+ "Дом - 20\n"
+ "Корпус - 1\n"
+ "Строение - \n"
+ "Квартира - 34\n"
+ "Время забора документов - 13:00 - 16:00\n"
+ "Комментарий - Код домофона 39ключ7289";
final String subst = "\\1,\\3,\\5,\\7,\\9,\\11,\\13,\\15,\\17,\\19,\\21,\\23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}