$re = '/(Заявка на забор документов)\n(Имя - )(.*)\n(Фамилия - )(.*)\n(E-mail - )(.*)\n(Мобильный телефон - )(.*)\n(Улица - )(.*)\n(Дом - )(.*)\n(Корпус - )(.*)\n(Строение - )(.*)\n(Квартира - )(.*)\n(Время забора документов - )(.*)\n(Комментарий - )(.*)/m';
$str = 'Заявка на забор документов
Имя - Владимир
Фамилия - Симигин
E-mail - v.simigin@gmail.com
Мобильный телефон - +79141861116
Улица - Большая Черемушкинская
Дом - 20
Корпус - 1
Строение -
Квартира - 34
Время забора документов - 13:00 - 16:00
Комментарий - Код домофона 39ключ7289';
$subst = "\1,\3,\5,\7,\9,\11,\13,\15,\17,\19,\21,\23";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;