# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(Заявка на забор документов)\n(Имя - )(.*)\n(Фамилия - )(.*)\n(E-mail - )(.*)\n(Мобильный телефон - )(.*)\n(Улица - )(.*)\n(Дом - )(.*)\n(Корпус - )(.*)\n(Строение - )(.*)\n(Квартира - )(.*)\n(Время забора документов - )(.*)\n(Комментарий - )(.*)"
test_str = ("Заявка на забор документов\n"
"Имя - Владимир\n"
"Фамилия - Симигин\n"
"E-mail - v.simigin@gmail.com\n"
"Мобильный телефон - +79141861116\n"
"Улица - Большая Черемушкинская\n"
"Дом - 20\n"
"Корпус - 1\n"
"Строение - \n"
"Квартира - 34\n"
"Время забора документов - 13:00 - 16:00\n"
"Комментарий - Код домофона 39ключ7289")
subst = "\\1,\\3,\\5,\\7,\\9,\\11,\\13,\\15,\\17,\\19,\\21,\\23"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.