# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\d{1}\)/\r/g;t' <<< "5)Passenger Lifts - Insurance - The High St 5-16- due - 28 Jan 22, 5)Passenger Lifts - Insurance - 6 Lovedale Road Flats- due - 09 Sep 21, 5)Passenger Lifts - Insurance - Queens Court 1 - 31 BLOCK- due - 14 Jan 22
"