import re
regex = re.compile(r"\d{1}\)")
test_str = ("5)Passenger Lifts - Insurance - The High St 5-16- due - 28 Jan 22, 5)Passenger Lifts - Insurance - 6 Lovedale Road Flats- due - 09 Sep 21, 5)Passenger Lifts - Insurance - Queens Court 1 - 31 BLOCK- due - 14 Jan 22\n")
subst = "\\r"
result = regex.sub(subst, test_str)
if result:
print(result)