#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(MAINT|(STRY|PRB)-\d+):\s*(?i:\w*(e[a-ce-z]|[a-df-z]d|i(n[a-fh-z]|[a-mo-z]g|e[a-ce-z]|[a-df-z]d)|[a-hj-z]ng|[a-hj-z][a-df-mo-z][a-cefh-z])|\w)\s([a-zA-Z0-9._\-"].*)"
Local $sString = "MAINT: Refactor something" & @CRLF & _
"STRY-1: Add something" & @CRLF & _
"STRY-1: popoinfe something" & @CRLF & _
"STRY-2: Update something" & @CRLF & _
"" & @CRLF & _
"But should not match the following:" & @CRLF & _
"" & @CRLF & _
"MAINT: Refactored something" & @CRLF & _
"STRY-1: Added something" & @CRLF & _
"STRY-2: Update something" & @CRLF & _
"" & @CRLF & _
"MAINT: Refactoring something" & @CRLF & _
"STRY-3: Adding something" & @CRLF & _
"STRY-4: Updating something"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")