re = /^(MAINT|(STRY|PRB)-\d+):\s*(?i:\w*(e[a-ce-z]|[a-df-z]d|i(n[a-fh-z]|[a-mo-z]g|e[a-ce-z]|[a-df-z]d)|[a-hj-z]ng|[a-hj-z][a-df-mo-z][a-cefh-z])|\w)\s([a-zA-Z0-9._\-"].*)/m
str = 'MAINT: Refactor something
STRY-1: Add something
STRY-1: popoinfe something
STRY-2: Update something
But should not match the following:
MAINT: Refactored something
STRY-1: Added something
STRY-2: Update something
MAINT: Refactoring something
STRY-3: Adding something
STRY-4: Updating something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end