import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(MAINT|(STRY|PRB)-\\d+):\\s*(?i:\\w*(e[a-ce-z]|[a-df-z]d|i(n[a-fh-z]|[a-mo-z]g|e[a-ce-z]|[a-df-z]d)|[a-hj-z]ng|[a-hj-z][a-df-mo-z][a-cefh-z])|\\w)\\s([a-zA-Z0-9._\\-\"].*)";
final String string = "MAINT: Refactor something\n"
+ "STRY-1: Add something\n"
+ "STRY-1: popoinfe something\n"
+ "STRY-2: Update something\n\n"
+ "But should not match the following:\n\n"
+ "MAINT: Refactored something\n"
+ "STRY-1: Added something\n"
+ "STRY-2: Update something\n\n"
+ "MAINT: Refactoring something\n"
+ "STRY-3: Adding something\n"
+ "STRY-4: Updating something";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}